* Messages et Sujets Récents
topic Télé Fr [Gotham/Frodo/Eden]
[LIVE TV]
Laurent-C
Aujourd'hui à 13:22:30
topic Playlist TVIFR
[LIVE TV]
rorony
Aujourd'hui à 13:03:47
topic Échange et partage de sources vidéo LIVE
[LIVE TV]
Angelscry
Aujourd'hui à 12:32:00
topic Proleme samba
[Support OpenELEC]
Lyksyr
Aujourd'hui à 12:03:33

Pages: 1 2 [3]  Toutes   Bas de page
  Imprimer  
Auteur Fil de discussion: Télécommande sous Xbmc  (Lu 29148 fois)
0 Membres et 1 Invité sur ce fil de discussion.
Par Bélénos, Par Toutatis, par Amora!
Fait partie du Décor
*
Alcoolémie: 75
Messages: 19321
Hors ligne Hors ligne
Sexe: Homme
Romain, tu ne feras pas la loi dans notre village!
WWW
« Répondre #40 le: 20 Octobre 2008 10:57:03 »

Merci  smiley
Journalisée

Je me suis construit une Roulotte, ce n'est pas pour voir les châtelains traîner sur mon terrain vague

« « Tout homme qui fait quelque chose a contre lui ceux qui font la même chose, ceux qui font exactement le contraire et l'immense majorité de ceux qui sont d'autant plus critiques qu'ils ne font rien du tout. » » (René Char)


Comment récupérer les logs et décrire un problème avec un script/plugin
AppleTV + Carte accélératrice Crystal HD / Xbox Débug Kit.
Explorateur
*
Alcoolémie: 0
Messages: 3
Hors ligne Hors ligne
« Répondre #41 le: 25 Avril 2009 17:39:58 »
Haut de page

Bonjour

J'ai réussi à faire fonctionner ma télécommande Xbox sous ubuntu 8.10 et 9.04 en suivant les explications ici (post de Koshari):
Lien
Mais pour xbmc rien ne fonctionne, "XboxDVDDongle" est pourtant dans mon fichier lircmap.xml
Quelqu'un a une idée?  smiley
Pour le pad Xbox, j'ai un message  au démarrage de xbmc(9.04)  qui me confirme qu'il est reconnu, mais rien ne marche  sad

Merci
Journalisée
Grimoire
Fait partie du Décor
*
Alcoolémie: 4
Messages: 1006
Hors ligne Hors ligne
Sexe: Homme
Oook.
« Répondre #42 le: 26 Avril 2009 22:00:38 »
Haut de page

Et en faisant l'essai par la commande irw dans un terminal, ça marche?
Journalisée

Explorateur
*
Alcoolémie: 0
Messages: 3
Hors ligne Hors ligne
« Répondre #43 le: 26 Avril 2009 23:24:45 »
Haut de page

Oui Cricket, la commande irw fonctionne alors je pense qu'il y a juste une configuration de xbmc à faire..
Journalisée
Grimoire
Fait partie du Décor
*
Alcoolémie: 4
Messages: 1006
Hors ligne Hors ligne
Sexe: Homme
Oook.
« Répondre #44 le: 29 Avril 2009 14:54:13 »
Haut de page

En théorie, si irw passe et que tu as correctement mappé XBMC (nom de la télécommande et nom des touches correspondant au retour de irw), ça devrait passer...
Journalisée

Explorateur
*
Alcoolémie: 0
Messages: 3
Hors ligne Hors ligne
« Répondre #45 le: 01 Mai 2009 11:27:07 »
Haut de page

Pour info, la télécommande fonctionne sans aucune modification de xbmc depuis la 9.04 RC1  smiley
« Dernière édition: 07 Mai 2009 11:57:36 par eddween » Journalisée
Contributeur
*
Alcoolémie: 0
Messages: 16
Hors ligne Hors ligne
« Répondre #46 le: 22 Août 2009 18:42:59 »
Haut de page

Bonjour,
Moi quand quand je lance irw et que j'appuie sur une touche de ma télécommande (celle de la Hauppauge winTV nova-t stick), j'ai pas de code de ce genre "000000014fa250000 00 KEY_PLAY RF_ME_Remote_Control".
Par exemple, pour la touche 1 j'ai "&" qui correspond à la touche 1 du clavier quand on appuie pas sur shift.
Comment je fais pour modifier le fichier lircmap.xml?

Post Merge: 22 Août 2009  21:38:55
Finalement c'est bon j'ai réussi. J'ai suivi ce tuto http://www.linuxtv.org/wiki/index.php/Hauppauge_WinTV-NOVA-T-Stick#Remote_control_support
Mai j'ai quelques touches qui ne répondent pas comme "ok".
Quelqu'un sait comment faire pour que toutes les touches marchent?

Post Merge: 23 Août 2009  09:35:45
C'est bon, tout marche très bien. J'ai suivi le tuto jusqu'à la fin. Si quelqu'un à des problèmes avec cette télécommande et lirc, je suis là.
« Dernière édition: 23 Août 2009 09:35:45 par mancool » Journalisée
Philx
« Répondre #47 le: 27 Octobre 2009 14:40:33 »
Haut de page

J'ai le même problème que toi Mancool, j'ai des touches qui ne fonctionnent pas. Comment as-tu résolu ce problème ?
Journalisée
Contributeur
*
Alcoolémie: 0
Messages: 16
Hors ligne Hors ligne
« Répondre #48 le: 27 Octobre 2009 17:21:03 »
Haut de page

T'as suivi le tuto du lien que j'ai mis?
Journalisée
Explorateur
*
Alcoolémie: 0
Messages: 2
Hors ligne Hors ligne
« Répondre #49 le: 29 Octobre 2009 20:21:42 »
Haut de page

Oui j'ai suivi le tutoriel jusqu'à la fin, mais je pense qu'il n'est pas complet. Ou bien j'ai raté un épisode.
Je vous mets ma config :
Ubuntu Mini X64 8.10 (intrepid), avec XBMC. J'ai suivi le guide :
http://xbmc.org/wiki/index.php?title=HOW-TO_install_XBMC_for_Linux_on_Ubuntu%2C_a_Step-by-Step_Guide&oldid=12597
Ce guide n'est plus supporté, mais c'est le seul qui me donne une vidéo fluide sans acoups sous XBMC.
au boot, je vois en tapant "ps -A" que inputlirc est présent.
Quand je lance irw (sans être sous X-windows), j'obtient :
"160 0 KEY_OK dvb-ir"
si je lance "sudo /usr/sbin/lircd -H devinput -d /dev/input/dvb-ir", puis irw, j'obtient :
"0000000000010160 00 OK Hauppauge_A415"
une fois X-windows démarré (démarré avec XBMC fullscreen), les touches de direction, volume, mute fonctionnent, pas les autres. Quelque soit ma config du fichier Lircmap.xml (xbmc), ça ne change rien.
A priori le composant HAL traite les télécommandes comme des claviers, j'ai donc modifié le fichier lirc.fdi, en indiquant le nom de ma télécommande comme spécifié, et effectivement j'obtient un fonctionnement un peu différent : seules les touches de direction ont une action. J'arrive à mapper les touches numériques et à leur attribuer une fonction qui s'effectue comme voulu, mais la plupart des autres touches, comme la touche OK ne fonctionnent pas, et ne sont pas vu dans le log "xbmc.log". Les fichiers lircd.conf et hardware.conf semblent bien configurés.

Qu'est-ce que je fais mal ?
Mancool, qu'as-tu fais entre tes 2 posts pour que toutes les touches fonctionnent ?
Journalisée
Contributeur
*
Alcoolémie: 0
Messages: 16
Hors ligne Hors ligne
« Répondre #50 le: 30 Octobre 2009 11:54:45 »
Haut de page

Quelle télécommande et tuner as-tu?
Journalisée
Explorateur
*
Alcoolémie: 0
Messages: 2
Hors ligne Hors ligne
« Répondre #51 le: 30 Octobre 2009 19:39:05 »
Haut de page

J'utilise la télécommande Hauppauge grise et noire qui est livrée avec le tuner USB Nova-T-HD. La référence sous les piles : A415-HPG-A. Sachant qu'au final je vais utiliser la logitech Harmony 515 qui est programmable.
Journalisée
Contributeur
*
Alcoolémie: 0
Messages: 18
Hors ligne Hors ligne
Sexe: Homme
« Répondre #52 le: 30 Janvier 2010 23:05:15 »
Haut de page

Bonjour,

je viens de decouvrir xbmc, je travaille sur l'installation de ce superbe soft depuis une bonne semaine maintenant.
J'ai decide d'utiliser la version linux.
J'ai pas mal avancé, il m'a fallu pas mal de temps pour configurer mon tunner TNT, mais aujourd'hui ca marche.
Je bloque par contre sur la telecommande : elle fonctionne avec lirc. j'ai bien des reponse quand je lance irw.
Par contre rien dans xbmc.
J'ai crée un fichier lircmap.xml, mais rien....
Je bloque malgré tout ce que j'ai pu lire a droite ou a gauche...

Merci de votre aide.
Journalisée

Ni pour ni contre... bien au contraire !
ElkAiN
« Répondre #53 le: 31 Janvier 2010 15:24:47 »
Haut de page

Salut,
Je suis un peu dans le même cas que toi, Sous Ubuntu ma télécommande fonctionne (irw OK, le pointeur de la souris bouge avec le pad) mais sous xbmc rien.
Dans les logs je n'ai rien de relatif à Lirc.

J'ai par ailleurs essayé en lançant:
Code:
lircd -o /dev/lircd
Et là je peux déplacer le pointeur de la souris avec le pad (comme sous Ubuntu) mais pas plus. Une fois lircd lancé avec cette option, il m'est impossible de lancer "irw".

Essaye de lancer lircd comme ça et dis moi quel est ton résultat.

Merci
Journalisée
Contributeur
*
Alcoolémie: 0
Messages: 18
Hors ligne Hors ligne
Sexe: Homme
« Répondre #54 le: 02 Février 2010 23:23:30 »
Haut de page

Bonsoir,

Bon j'ai recommencer tout depuis 0 !! Mais je crois que c'est une chose courante sur le forum ;-)

Je suis parti de Karmic, et cette fois je n'ai pas eu de soucis une fois Lirc correctement configurer j'ai modifier mon lircmap.xml que j'ai copié dans /home/xbmc/.xbmc/system et là tout roule.
Bon faudra surement faire quelque retouche mais ca marche.
Si necessaire je tiens a votre disposition mes fichiers : lircd.conf, hardware.conf et lircmap.xml il n'y a qu'à demander...
Bon j'y retourne il me reste encore a faire tourner mon double tunner et quelques optimisation car mon HTPC rame a mort si une video tourne et que je fais afficher le menu par dessus...

Merci...
Journalisée

Ni pour ni contre... bien au contraire !
Pages: 1 2 [3]  Toutes   Haut de page
  Imprimer  
 
Aller à: